Integrate R StateEt as Eclipse Plugin

Follow these steps to install the R StatET
eclipse plugin on Windows. The installation

instructions are at

http://www.walware.de/goto/statet

Step 1: First, install R using the web site:
http://cran.us.r-project.org/

Make sure you remember the folder in which you
choose to save R.

Next install the packages rj and rlava.

Install the R packagesgj from the website: )
http://www.walware.de/?page=/it/downloads/rj.mfr
ame

You can do that in the rGui.

For example, if R is in the file location C:\Program
Files\R\R- x.x.x

The Rgui.exe is then found at C:\Program Files\R\R-
x.x.x\bin\i386

Next enter the following three command into the
Rgui:



http://www.walware.de/goto/statet
http://cran.us.r-project.org/
http://www.walware.de/?page=/it/downloads/rj.mframe
http://www.walware.de/?page=/it/downloads/rj.mframe

install.packages(c("rj", "rj.gd"),
repos="http://download.walware.de/rj-
1.1")

install.packages ("rJava")

These packages can be copied into the folder:
.../R-x.x.x [library.

Step 2: Go to the site which hosts the
WalWare plugin software

http://www.walware.de/goto/statet
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Follow the installation link on this site to
get the URL from which Eclipse can be
download and install the software.

Step 3: Install Eclipse

http://www.eclipse.org/downloads/
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| downloaded

eclipse-jee-kepler-SR1-win32-x86_64.zip


http://www.eclipse.org/downloads/

and unzipped it into my C:\Program Files
folder. | also added the eclipse executable
to my task bar by using a right click on the

eclipse application and choosing the option:



Name Date modified Type Size
I configuration 11/27/2013 3:45 PM  File folder
| dropins 9/19/2013 @07 AM  File folder
| features 11/27/2013 3:45 PM  File folder
I p2 11/27/2013 3:45PM  File folder
| plugins 11/27/2013 3:46 PM  File folder
I readme 11/27/2013 3:46 PM  File folder
eclipseproduct  11/27/2013 3:45 PM  ECLIPSEPRODUCT File 1KB
artifacts 11/27/2013 345 PM XML Document 115 KB
‘9 eclipse 11/27/2013 3:45 PM  Application 305 KB
4 eclipse 11/27/2013 3:45 PM  Configuration settings 1KB
7 eclipsec 11/27/2013 3:45 PM  Application 18 KB
epl-v10 11/27/2013 3:45PM  HTML File 17 KB
notice 11/27/2013 3:45PM  HTML File 10 KB

add to task bar.

Step 4: Install the StatEt software into

Eclipse by using the instructions at

http://help.eclipse.org/kepler/index.jsp?topi



http://help.eclipse.org/kepler/index.jsp?topic=/org.eclipse.platform.doc.user/tasks/tasks-124.htm

c=/org.eclipse.platform.doc.user/tasks/tasks-

124.htm

Open Eclipse and go to

Help -> Install New Software.


http://help.eclipse.org/kepler/index.jsp?topic=/org.eclipse.platform.doc.user/tasks/tasks-124.htm
http://help.eclipse.org/kepler/index.jsp?topic=/org.eclipse.platform.doc.user/tasks/tasks-124.htm
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Step 5: Paste the URL for the Eclipse version you chose
into the box. | chose

http://download.walware.de/eclipse-4.3



http://download.walware.de/eclipse-4.3

Aode] - Word ?

File Edit Source Refactor Navigate
]

12 Package Explorer =8
B%|w ~
& BookCode
» & MachineleamingAction
» & MachineLeamingAdvanced
+ & Recommender
+ & TextProcessing
» & TipsTricks
+ & Torgo
4 & UCSantaCruzSurveyCourse
v @& Cluster
» & Dataxploration
© & DecisionTrees
© (& EnsembleMethods
© @& KNN&NaiveBayes
i & LinearModels.
» & Mare
& Multiclass&ROC
© @ Projects
& SupportVectorMachine
12 3dimTreeR

oS HE

Avallable Software E
Select a site or enter the location of a site. y,
http//download walware.de/eclipse-4.3] v | ‘ Add... |
Find more software by working with the "Available Software Sites” preferences.
[ type filter text
Name Version
[]@ There is no site selected.
Select All Deselect All
Details
[¥]Show only the latest versions of available software [] Hide items that are already installed
[v] Group items by category What is already installed?

[ Show anly software applicable to target environment
[w] Contact all update sites during install to find required software

UCSantaCruzSurveyCourse

@ <oack Nert» e

Click Add and then select All




Word " | Available Software
RS Check the items that you wish to install] élg
Workwith: | StatEt - http://download walware de/eclipse-4.3 | Add..
Find more software by working with the “Available Software Sites” preferences.
B8l 7 type filter text
& BookCode
© & MachineleamingAction Nama Version
© & MachineLeamingAdvanced - [V]50 WalWare - Libraries
| & Recommender []99 WalWare - StatET
+ & TextProcessing [w]5m WalWare - Utilities
& TipsTricks
e & Torgo
4 & UCSantaCruzSurveyCourse
@ Cluster
& Databxploration
- & DecisionTrees ——
> SelectAll | | Deselect All 18 items selected
- & KNN&NaiveBayes =
. @ LinearModels Deial
.+ & More
2 Multiclass&ROC
& Projects [ Show only the latest versions of available software [_] Hide items that are already installed
+ & SupportVectorMachine = fiema by el %
2 3dimTreeR (O s by ooy e
E [ Show only software applicable to target environment
[}
"% ¥ Contact al update sites during instal to find required software
D
. <
UCSantaCruzSurveyCourse ® < Back Next > Finish | Cancel

Continue to select next and accept the terms and

conditions. Finally restart Eclipse.

Step 6: Select the R Environment preference page by




clicking on the red circle below:
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(Another way to get to this screen is to use the
“Window” pull down tab at the top of the screen and



selecting:
Window>preferences>StatET>Run/Debug>R

Environments)

Clicking on the 'Add...” button opens the dialog to
specify the new R environment.
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Next let eclipse know where you downloaded R in your file
system. Fill out the form as given below. By clicking on the
small + sign you can browse your file system. Finally, click on
“Detect Default Properties/Settings” and then click on OK.



Name: ‘Any Name You Choose ‘

Location (R HOME): {Place in your File System of your downloaded R |
Architecture: Detect Default Properties/Settings
Libraries: = Additional Libraries (R_LIBS) Add..
=) User Libraries (R_LIBS_USER)
4 B Site Libraries (R_LIBS_SITE} Remove

(2 §{env_varR_HOME}/site-library
4z Default Library
& ${env_varR_HOME}/library

Advanced - Installation locations:

Documentation (R DOC_DIRY:  Sfenv varR HOME}/doc 4
Shared files (R SHARE DIRY:  $fenv_varR HOME}/share 4
Include fles (R INCLUDE_DIR): | Sfenv_varR HOME}/include I+




Step 7: Set up the console.

First, notice that you can open the StatET
perspective by clicking on the box in the top right
corner and choosing StatET. Another way to open it
is under the Window tab selecting Window>Open
Perspective>Other>StatET.
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Go to the menu: Run > Run Configurations as below:



Note that it is possible to create
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By selecting ‘R Console’, options for creating a new
console, copying a console, or deleting a console are

given.



When creating a new console, a dialog form will
appear. Inthe run dialog select ‘R Console’ and click
the ‘New launch configuration’ button. Enter a name
for the configuration, for example ‘R-3.0.2’.

In the Main tab you can specify the working
directory. (I have my data sets stored in the folder
C:\Dev\workspaceR\TestDataSets.) You can leave it
blank then the R system will choose the default
working directory. Or you could enter variables like
S{project path}. Then in this case the working
directory for the R session will be set to the selected
project in the ‘Navigator’ view.

In the Main tab you can also specify R start up
options. For example, --silent causes R to start up
without printing start up messages. Another Main
tab option is --no-save or --no-restore, to be used
when invoking R.

After clicking on ‘Apply’, the new console is created.
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Next, go to the ‘R Configuration’ tab and select an R
configuration (I selected R-3.02 which is the version



of R for this console.) Now click on ‘Apply’ to save
the configuration.

Create, manage, and run configurations @

Runa R Console.

LExB%~ Name: R302 \
lopefitertet || Eyn i R Conig . R Console| 8 Environment| 2 JRE | % Java Classpath % Source = Common)|
B3 Java Applet R Environment:
[3] Java Application
o lnit (O Workbench Default: ~ R-302
m Maven Build ® Selected C S |R—3.0.2 v ‘ ‘Configme,._‘
4 B R Console
B R-301
EiR-302
BRat
B R2131

B} RI2131-Rterm
ER R Remote Console
Ju Task Context Test

Filter matched 12 of 12 items Apply Revert

®

Step 7: Now it is time to start the R console by



clicking on ‘Run’ to run the R console (as seen at the
bottom right of the previous screen shot).

After ‘Run’ is clicked, the console appears as in the
following screen shot:
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R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditio

Type 'license()' or 'licence()' for distribution details.

<idle>

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publicatio

Type 'demo()' for some demos, 'help()' for on-line help,
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

[Previously saved workspace restored]

[INFO] Updating the R environment index started...

[INFO] The R enviromment index was updated successfully. |

> Submit
< )

Click on '0K' to save the new R emironment and
close the preforences dialog

= R Console Launch Configuration

B

@

Next, you need a launch configuration or the R corsale:

Goto Rum > Run Configurations..”

Dauble-cick on R Console'to create a new
canfiquation.

Specity a Name'and edit al tabs ofthe new
launch configuration.

Add suitable Options nthe Main ta i desred,
Such a5 --n0-5ave of ~no-estore o Be used when
mvoking R.

Specy the R Environment o be used inthe R
Confitab. Thi can be the defaut R Emircnment

‘or any other R Environment that has been defined.

Optionally check the bax in the Common tab to
list this R Launch configuration in the Favorites
meny

Cickon ‘Apply ta savethe R Launch Conliguration

= Launch the R console
Cick an Run in the Run Diaag for th R Launch
configuration you created

The R Cansale will be launched and ready for use from
‘within Eclipse.

Note that sometimes you may not run the R console,
the ‘Run’ button is grayed. This can happen for
example when no project is selected but you have set




R to start with $S{project path} as the working
directory.

Once the R Console has been setup, the next time
you start Eclipse it can be ran again from the ‘Run As’
button menu on the main toolbar of Eclipse as
highlighted below:

Step 8: Run an R program

Commands can be typed into the R console and will
be executed simply by hitting the ‘Enter’ key.

New R scripts can be created by using the ‘File’ pull
down menu and selecting File>New>R Script File as
seen in the following screen shot:
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The following Run options are taken verbatim from
Lam’s document. Run R Script in R via “source': The
complete contents of the text editor is entered in R
through the source command in R. In contrast to the



above method, only one command is run in R:
source(<selected text file>)

Run R selection/current line in R: If a block of code is
selected then only that block of code is sent to R. If
nothing is selected, only the current line (the line of
code where the cursor is) is sent to R.

Run R selection/current line in R and go to the next
line Does the same as the above but moves the
cursor to the next line in the text editor. This might
be useful to run some block of statements line by
line.

Run Function Definition in R This option is not
accessible from the menu but is accessed by the short
cut key Ctr+R, Ctr+F. In a text editor, if the cursoris in
a function definition then use the short cut key to
submit the function definition. StatET will recognize
the beginning and the ending of the function. The
user does not need to select the whole function and
use ‘run R selection' to define the function.



